Okay
  Public Ticket #2666870
Kalium theme package - links to assets broken
Closed

Comments

  •  4
    jgorres started the conversation

    Hi,

    Using a link checker on a site I created I discovered various items where links are broken due to wrong file names in the Kalium theme package.

    You will find various files below

    • /wp-conten/themes/kalium/assets/vendors/ and
    • /wp-conten/themes/kalium/assets/images /

    with an "@" in their file names. Should be replaced with an "_".


    Regards,
    Jörn.

  •  599
    Arlind replied

    Hi Jörn,

    If it possible to see the errors generated in browser regarding these resources?

    Depending on your list, in "wp-conten" is an invalid folder name, WordPress has this named "wp-content", maybe this is causing these issues?!

    Kind regards,
    Arlind


      Documentation         Join Kalium Users Group

  •  4
    jgorres replied

    Sorry, the "wp-conten" is a typo.

    I just checked (again) in the downloaded package:

    • kalium/assets/vendors/nivo-lightbox/themes/default/loading@2x.gif
    • kalium/assets/vendors/nivo-lightbox/themes/default/prev@2x.png

    They are not the only ones, there are some more below /assets/.

  •  599
    Arlind replied

    Hi Jörn,

    I've checked these files in my local copy of Kalium and they do exist:

    medium
    (view large image)

    If you have installed the theme via FTP it may happen for some files to fail on uploading so to make sure you have uploaded all the files is by uploading the theme via WordPress. 

    However if this is not the case can you please send me your credentials so I will troubleshoot the problem  on your site.

    Kind regards,
    Arlind


      Documentation         Join Kalium Users Group

  •  4
    jgorres replied

    Hi Arlind,

    The problem is:

    The file names in the Kalium package are "bla@blubb.ext".

    The various pages are linking to "bla_blubb.ext".

    For this reason the link checker tells me that there are broken links. I simply adjusted the file names on my site.

    However, the problem should be tackled at the very beginning and that is the Kalium package provided by you via Themeforest.

    Regards,
    Jörn.

  •  599
    Arlind replied

    Hi Jörn,

    Yes I understand however when I test in our site there are no reported errors when I open nivo-lightbox gallery as you can see in the video below:

    https://d.pr/v/tE7msD

    The broken link checker may check the links in different context however in general usage in our site they are not broken as the video above proves it.

    Am I doing something wrong of the theme assets really are messed up?!

    Kind regards,
    Arlind


      Documentation         Join Kalium Users Group

  •  4
    jgorres replied

    Hi Arlind,

    I do not understand what you mean by:

    "Am I doing something wrong of the theme assets really are messed up?!"

    Please explain.

    Regards,
    Jörn.

  •   Arlind replied privately